Slider Issue on tablet and mobile display

Home Support Super Construction Plus Slider Issue on tablet and mobile display

This topic contains 3 replies, has 2 voices, and was last updated by  ProDesign Support 3 weeks, 1 day ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #17078

    jc_anchor555
    Participant

    I have tested my site now that it is loaded to a preview folder on live server and it matches the identical problem I find on https://www.prodesigns.com/wordpress-themes/demo/super-construction-plus/

    In desktop display size the slider images and read more links behave exactly as expected.

    When I shrink the display size down to tablet or mobile width all expected behavior breaks down. I found that first slide is the only one that displays correctly on a new page refresh. On this first slide the button and link works correctly.

    After that all links and button positions are exacty one slide behind. This error continues indefinitely until the user either refreshes page or manages to click a button position from the previous slide which also takes them to the previous link.

    I turned off all settings trying to see if a setting, overlay, or autoplay was causing the problem. The behavior remains the same no matter how many settings you turn on or off.

    It may be a javascript or css issue or combination of the two. When you move your cursor over the previous read more button position, the finger pointer appears along with a link display at the bottom of screen for the previous slide.

    Would love it if there is a fix we can implement for tablet and mobile users which are half to 3/4 of our users. Otherwise it is a wonderful template!

    Thanks for your help.

    #17079

    jc_anchor555
    Participant

    One more tidbit I just noticed is that if I restore the screen size to desktop width or larger, the error immediately corrects itself without performing a page refresh. So the script is working consistently.

    Hope that helps!

    #17115

    jc_anchor555
    Participant

    I loaded the latest version of Slick which is what the home page slider is built with and they have not resolved that issue.

    This theme uses jQuery by default. I tried a different slider well rated but conflict with jQuery caused it not to work. So I went looking for a slider plugin built with jQuery and that was successful.

    So I am now running “Slide Anything” which is built with Owl Carousel 2 and jQuery found here:
    https://wordpress.org/plugins/slide-anything/

    I deactivated the home page slider in Appearance > Customize > Feature Slider Options

    Then I went into widgets and added a text field at the top of the Home Page Widget Area. There you can add a shortcode to whatever slider you create and it works.

    Last step is to add some custom css to get the slide show to appear the way you want.

    #17125

    Hello There!

    Hope you are doing good!

    We have checked the details and the issue is because of the plugin used in the theme. Please have a look at the forum: https://github.com/malsup/cycle2/issues/437 to have a better idea.

    In the forum, you will come across a solution to this issue, you have to add custom CSS

    .cycle-slide.cycle-slide-active{z-index:150 !important;}

    If you will add CSS then slider transition will not be available so if you are planning to have a transition then it will be better to add shortcode of another slider.

    Hope this helps!

    Have a great day ahead!

    Regards,
    Team ProDesigns

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.